Drupal 7 used jQuery 1.5.x by default. In Backdrop, the version has been updated to 1.11.0.

For all API changes between these versions of jQuery, see the jQuery API website:

http://api.jquery.com/category/version/1.6/
http://api.jquery.com/category/version/1.7/
http://api.jquery.com/category/version/1.8/
http://api.jquery.com/category/version/1.9/
http://api.jquery.com/category/version/1.10/
http://api.jquery.com/category/version/1.11/

Introduced in branch: 
1.0.x
Introduced in version: 
1.0.0
Impacts: 
Module developers
Theme developers
Related Github Issues: 
https://github.com/backdrop/backdrop-issues/issues/57